Специальные цены   новые товары
+ Ответить в теме
Страница 327 из 334 ПерваяПервая ... 317 325 326 327 328 329 ... ПоследняяПоследняя
Показано с 13,041 по 13,080 из 13339

Подвес камеры на бесколлекторных моторах на Alexmos/Basecam

Тема раздела Коптеры. Комплектующие, сборка, настройка. в категории Квадрокоптеры и мультироторы; Сообщение от almazini красным я пометил где у меня находится датчик. может ли быть проблема обусловлена тем что он находится ...

  1. #13041

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Цитата Сообщение от almazini Посмотреть сообщение
    красным я пометил где у меня находится датчик. может ли быть проблема обусловлена тем что он находится не на оси мотора2 ??

    upd2:
    раньше у меня датчик стоял внизу т.е. снизу камеры... а теперь датчик стоит вверху
    Конечно нужно менять: либо датчик разместить в пространстве так же как было (что в вашем случае не удобно и вероятно невозможно) либо в настройках подвеса изменить направление осей вверх и вправо.
    Если правильно помню у этих подвесов прошивка Alexmos 2.1 была и непрошиваемая на другую. GUI соответственно можно попробовать с сайта basecam electronics скачать.
    Там прямо на первой закладке будет Базовые настройки и расположение осей IMU относительно его местоположения.
    Осмелюсь предположить что изначально датчик был закреплён ПОД камерой на оси pitch, и думаю что настроен был ось вверх: Z, ось вправо: -Y (или Y);
    Если это так, то теперь датчик у вас расположен на той же оси pitch, но ЗА камерой, соответственно должно быть ось вверх: X, ось вправо: -Y(или Y) (так как тут не изменилось)
    А лучше сфоткайте точно где датчик был и где стал, а то по рисунку выходит что вроде как он не менял своё положение.

  2.  
  3. #13042

    Регистрация
    13.09.2012
    Адрес
    Vilnius
    Возраст
    31
    Сообщений
    40
    Цитата Сообщение от Neo0 Посмотреть сообщение
    А лучше сфоткайте точно где датчик был и где стал, а то по рисунку выходит что вроде как он не менял своё положение.
    все барахло дома в разобранном виде.
    попробую еще раз показать на имеющихся фотографиях:


    вверху это то как было. датчик был закреплен под площадкой на которой устанавливается камера (там приклеен белый стикер на фото)

    на второй фото датчик закреплен уже на верхней рамке. соответственно в пространстве он перекручен на 180 градусов


    Думаю попробовать приклеить датчик так как он был изначально на новую конструкцию и посмотреть поможет ли это

  4. #13043

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    То есть если я верно понял то был ПОД камерой, а теперь НАД ней, при этом из за того что плоская сторона одна пришлось перекрутить его на 180*.
    Тогда всё равно нужно указать в настройках что ось вверх теперь -Z (а не Z как была), ну и ось вправо посмотреть не изменилась ли.

  5. #13044

    Регистрация
    13.09.2012
    Адрес
    Vilnius
    Возраст
    31
    Сообщений
    40
    Цитата Сообщение от Neo0 Посмотреть сообщение
    То есть если я верно понял то был ПОД камерой, а теперь НАД ней, при этом из за того что плоская сторона одна пришлось перекрутить его на 180*.
    Тогда всё равно нужно указать в настройках что ось вверх теперь -Z (а не Z как была), ну и ось вправо посмотреть не изменилась ли.
    да именно так. из-за того что крепиться датчик только одной стороной - там где плата плоская то он теперь перевернут на 180 градусов.

    вечером отпишу все ли хорошо работает

    спасибо

  6.  
  7. #13045

    Регистрация
    13.09.2012
    Адрес
    Vilnius
    Возраст
    31
    Сообщений
    40
    Цитата Сообщение от Neo0 Посмотреть сообщение
    То есть если я верно понял то был ПОД камерой, а теперь НАД ней, при этом из за того что плоская сторона одна пришлось перекрутить его на 180*.
    Тогда всё равно нужно указать в настройках что ось вверх теперь -Z (а не Z как была), ну и ось вправо посмотреть не изменилась ли.
    проверил вчера - переставил датчик на нижнюю планку - и всё заработало это плюс!
    минус в том что в некоторых положениях (наклоняя квадр на 45*) появляется дрож. начинает трястись мото номер 2 ... такого раньше тоже не было...

  8. #13046

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Цитата Сообщение от almazini Посмотреть сообщение
    ...начинает трястись мото номер 2 ... такого раньше тоже не было...
    Может нужно повысить P параметр? Развесовка изменилась же по идее.
    Хотя на моём тоже изначально был предел где то 45* так же тряслось, даже не думал над этим пока.

    Ковырял вчера снова подвес.
    Вспомнил что на DYS SMART 3 есть такое медное колечко как прокладка между подшипником статора и конструкцией. На схемах пишут что это колечко должно быть как раз на моторе по роллу.
    Но я когда собирал его поставил на питч. Хотя в принципе и без этого кольца всё свободно двигается без питания. Причём попробовал "вернуть" кольцо на ось ролл и видно что вал не входит до конца в крепёжное отверстие рамы. То есть прокладка как бы лишняя
    Но это так в порядке бреда, уже просто не знаю чё менять чтоб ролл заработал нормально.

    Попробовал вчера так же поменять местами каналы ролла и питча (хотя понимал что это бред), в итоге это не сработало, всё дрожало и не настраивалось в принципе. Видимо расходятся данные IMU и привязки канала к конкретной оси. Вернул как было.
    Так же пробовал настроить с нуля ось ролл и пробовал с десяток настроек. Не помогает. Ось ролл при отклонении по ней залипает и начинает низкочастотно возвращатся в пределах 5 градусов. То есть то в одном положении потом "едет" до другого и обратно.
    Подумываю проверить механику, может какой то незаметный изгиб всего плеча по роллу?
    Или взять у кого то такие же мозги или даже другие и проверить на них всю конструкцию с моторами. Заказал новые моторы но чую дело не в них(тем более что менял уже местами пару дне назад). Все фазы прозваниваются сейчас отлично.

  9. #13047

    Регистрация
    09.12.2008
    Адрес
    Астрахань
    Возраст
    50
    Сообщений
    2,508
    Цитата Сообщение от Neo0 Посмотреть сообщение
    ....

    Ковырял вчера снова подвес.
    ..........
    Ну что сразу на ум приходит?

    - провода точно не мешают на больших углах??? Или слишком жесткие? От датчика как проводочки идут? Если скручены в косичку - может попробовать разпустить (где то я читал, что скрученные могут давать то ли индуктивность... то ли еще что то, хотя вряд ли...)

    - на РОЛЛ - увеличить мощность (там есть основная и дополнительная мощность) - по чуть-чуть увеличивать, без фанатизма - на РОЛЛ нагрузка всегда больше.... - смотреть в программе - там все подсказки есть и подробно все расписано...


  10.  
  11. #13048

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Вообще никак не мешают По роллу же ещё и механический упор есть при 45*, проблема начинается задолго до него.
    Мощности увеличивал и уменьшал по всякому, брал даже готовые настройки людей у которых такой же подвес с rcgroups.com, безрезультатно.
    Проводки от IMU конечно не сплетены косичкой но идут рядом, так как они от серв мелких (в штатном кабеле они в принципе склеены параллельно в шлейф), и кабели одинаковые что на питч что на яв, но с ними такой фигни нет, при этом же менял IMU на другой от storm32 и ведёт себя ось точно так же, при том что обмотки то моторов менял местами.
    Вечером сфоткаю как всё выглядит, может сниму видео как сейчас ведёт себя подвес.

  12. #13049

    Регистрация
    09.12.2008
    Адрес
    Астрахань
    Возраст
    50
    Сообщений
    2,508
    Цитата Сообщение от almazini Посмотреть сообщение
    проверил вчера - переставил датчик на нижнюю планку - и всё заработало это плюс!
    минус в том что в некоторых положениях (наклоняя квадр на 45*) появляется дрож. начинает трястись мото номер 2 ... такого раньше тоже не было...
    Алексей, можно было и не переставлять...

    Надо скачать с сайта
    http://www.basecamelectronics.ru/simplebgc/
    руководство.
    Там все предельно просто и ясно расписано, как задать ориентацию датчика на рамке камеры...

    P.S. Стоит, кстати, и даже сейчас проверить правильность осей - может какая то из них "неправильная"...

    Цитата Сообщение от Neo0 Посмотреть сообщение
    ...
    Проводки от IMU конечно не сплетены косичкой но идут рядом, так как они от серв мелких (в штатном кабеле они в принципе склеены параллельно в шлейф),....
    У моего датчика - отдельные четыре проводка, и они были немного сплетены .... я их раскрутил....
    Еще у меня от камеры идут проводки...
    Вот по началу - иногда эти "кабельки" за что то цеплялись - и именно по роллу и было дрожание.... я это "засек" - проводочки расположил более "грамотно" - и все пашет четко

    А.... еще было дрожание на больших углах, вспомнил...

    Я вначале поставил резинки виброизоляции черненькие ОЧЕНЬ мягкие (штатные от коптера Quanum NOVA) - и вот прямо в руках запускаешь коптер с винтами, наклоняешь вперед сильно - и было самовозбуждение .... где то градусов 45 вперед - но по ПИТЧУ.

    Потом поставил резинки белые - от самой камеры от Фантома 2 Вижн - они и больше и жестче и материал у них больше "пластик" чем "резина"... как бы так выразится...
    И все - все работало четко.

    Но это с вибрацией. А на выключенном коптере (без вращения винтов) - ничего не было, даже на предельных углах...
    Миниатюры Миниатюры Нажмите на изображение для увеличения
Название: Снимок.jpg‎
Просмотров: 23
Размер:	64.0 Кб
ID:	1235166  

  13. #13050

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    У меня сейчас стоят резинки толстые и сильно мягкие работающие на растяжение (штатно стояли серие мелкие пожёстче и кажись на сжатие, но был флатер на видео), думаю даже слишком мягкие и возможно в этом проблема предельных углов, хотя держал и за плату на которой жёстко крепится мотор yaw и в принципе предельный угол и дрожание такой же.

    P.S. А у кого DYS SMART 3 посмотрите если не в лом где у вас видно медное колечко прокладка? Как то же оно должно было вставать. Чёт мне оно покоя не даёт

  14. #13051

    Регистрация
    09.12.2008
    Адрес
    Астрахань
    Возраст
    50
    Сообщений
    2,508
    Цитата Сообщение от Neo0 Посмотреть сообщение
    У меня сейчас стоят резинки толстые и сильно мягкие работающие на растяжение (штатно стояли серие мелкие пожёстче и кажись на сжатие, но был флатер на видео), думаю даже слишком мягкие и возможно в этом проблема предельных углов, хотя держал и за плату на которой жёстко крепится мотор yaw и в принципе предельный угол и дрожание такой же....
    Не. Мой, если держать подвес в руках - вообще работал четко и без вопросов...

    Еще, как вариант:
    - в программе настройки, там где параметры двигателя - проверить правильность этих параметров. Попробовать, сбросить все настройки и определить двигатели автоматически (кнопку нажать) - и посмотреть, что там наопределялось...

    И проверить - покрутить подвес....

    Потому как.... когда у меня были "непонятки" с бракованным двигателем - я нажимал эту кнопку - и один двигатель определял все правильно, а бракованный, с оборванной фазой, тоже определялся.... но с совершенно другими "характеристиками"....


  15. #13052

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Цитата Сообщение от Oleg_fly Посмотреть сообщение
    .... но с совершенно другими "характеристиками"....
    Кстати в этом что то есть. Когда делал авто определение то всегда то обратную полярность поставит на другом, то посчитает полюса не 14, а 18. Иногда нет.
    Но то было до обрыва и его устранения, плюс это не объясняет почему при смене местами статоров моторов с обмотками проблема остаётся на этой же оси уже с другим мотором. И авто определение делал вроде бы и уже после устранения проблемы с обрывом.
    Но попробую. А сбросить настройки имеете ввиду и PID или только полюсность моторов?

  16. #13053

    Регистрация
    09.12.2008
    Адрес
    Астрахань
    Возраст
    50
    Сообщений
    2,508
    Цитата Сообщение от Neo0 Посмотреть сообщение
    ....
    Но попробую. А сбросить настройки имеете ввиду и PID или только полюсность моторов?
    Та все сбросить - кнопку нажать....
    Если жалко их (настроек) - можно сохранить в файл, скриншотить.... записать, наконец, в блокнотик

  17. #13054

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Да эт понятно что я сохраню, вернее ещё в прошлом году сохранял когда всё работало. Сейчас уже и наизусть помню.
    Кстати если нажимаю "Настройки по умолчанию" то всё сбрасывается, но теряется 3-я ось по YAW. Как её вернуть без загрузки старого профиля непонятно. Она просто неактивна в GUI становится.

  18. #13055

    Регистрация
    15.06.2011
    Адрес
    Ростов-на-Дону
    Возраст
    45
    Сообщений
    865
    в ГУИ вкладка "Дополнительно" группа "Выходы на моторы" YAW: вместо "отключен" выбрать "YAW плата расширения"

  19. #13056

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Цитата Сообщение от Gapey Посмотреть сообщение
    в ГУИ вкладка "Дополнительно" группа "Выходы на моторы" YAW: вместо "отключен" выбрать "YAW плата расширения"
    Спасибо. Точно есть такое YAW ext.board

  20. #13057

    Регистрация
    14.09.2010
    Адрес
    Санкт-Петербург
    Возраст
    67
    Сообщений
    583
    Цитата Сообщение от ВДН Посмотреть сообщение
    Настроен подвес DYS с контроллером АлексМос 32 бит, 2 сенсора. Мозги коптера - Наза 2. Дома подвес с включенным коптером в руках работает, как часы. На поле, стоит поднять коптер, - подвес начинает дрейфовать по яву... Куда копать, коллеги?
    проблему так и не решил, отключил rc управление по яву (follow me включен) - все равно после взлета подвес ведет влево пока не упрется в механический ограничитель. Никто ничего не подскажет?

  21. #13058

    Регистрация
    09.12.2008
    Адрес
    Астрахань
    Возраст
    50
    Сообщений
    2,508
    Цитата Сообщение от Neo0 Посмотреть сообщение
    Кстати в этом что то есть. Когда делал авто определение то всегда то обратную полярность поставит на другом, то посчитает полюса не 14, а 18. Иногда нет.
    Но то было до обрыва и его устранения, плюс это не объясняет почему при смене местами статоров моторов с обмотками проблема остаётся на этой же оси уже с другим мотором. И авто определение делал вроде бы и уже после устранения проблемы с обрывом.
    Но попробую. А сбросить настройки имеете ввиду и PID или только полюсность моторов?
    Во... вот это уже на что то наводит....
    Должно быть и авто-определение и ручное - соответствовать заявленным хар-кам движка....
    Короче - сбросить все, пройти все пункты заново, делать все по этапам - и после каждого этапа проверять реальную работу...

    если например, после сброса и настройки двигателей и осей - все работает, например, а потом после следующего пункта начинает глючить - тогда есть куда копать...

    Кстати - попробовать в режиме двухосевого, без курсового канала - как оно???
    Или отключить ПИТЧ - и попробовать только РОЛЛ???
    Если РОЛЛ во всех случаях ведет себя хреново - тогда точно что то с этим каналом в самой плате....


    Цитата Сообщение от ВДН Посмотреть сообщение
    проблему так и не решил, отключил rc управление по яву (follow me включен) - все равно после взлета подвес ведет влево пока не упрется в механический ограничитель. Никто ничего не подскажет?
    А если Фоллоу Ми выключить?
    Последний раз редактировалось Oleg_fly; 26.07.2016 в 19:32.

  22. #13059

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Цитата Сообщение от Oleg_fly Посмотреть сообщение
    ...Или отключить ПИТЧ - и попробовать только РОЛЛ???
    Если РОЛЛ во всех случаях ведет себя хреново - тогда точно что то с этим каналом в самой плате....
    Скорее всего так и буду делать. Пока моторки новые не пришли особо вариантов нет.
    Предположим что так всё и останется по этой оси. Уже известны такие случаи и какой компонент на плате в этом случае меняли? Чип драйвера?

  23. #13060

    Регистрация
    14.09.2010
    Адрес
    Санкт-Петербург
    Возраст
    67
    Сообщений
    583
    Цитата Сообщение от Oleg_fly Посмотреть сообщение

    А если Фоллоу Ми выключить?
    завтра попробую.

    Сохранить

  24. #13061

    Регистрация
    09.12.2008
    Адрес
    Астрахань
    Возраст
    50
    Сообщений
    2,508
    Цитата Сообщение от Neo0 Посмотреть сообщение
    Скорее всего так и буду делать. Пока моторки новые не пришли особо вариантов нет.
    Предположим что так всё и останется по этой оси. Уже известны такие случаи и какой компонент на плате в этом случае меняли? Чип драйвера?
    Дальше уже не знаю... Если что то в плате - менять плату... ИМХО...
    Или у "практикующих" радиолюбителей спрашивать.... Я - радиолюбитель "теоретик", так сказать

  25. #13062

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Проверил ещё раз настройку с выключенными каналами кроме roll, настраивал с нуля. Эффект сохраняется при любых значениях.
    Так же снова менял местами двигатели, безрезультатно.
    Решил смотреть геометрию, снял плечо, есть расхождение осей (они не в одной плоскости и не под 90 градусов), не уверен до конца что это не норма для этого подвеса:

    Немного фоток, где видно что кабели точно не мешают, и какой тип демпферов сейчас:
    Миниатюры Миниатюры Нажмите на изображение для увеличения
Название: PicsArt_07-27-08.02.39.jpg‎
Просмотров: 19
Размер:	45.0 Кб
ID:	1235400   Нажмите на изображение для увеличения
Название: PicsArt_07-27-08.01.11.jpg‎
Просмотров: 16
Размер:	32.3 Кб
ID:	1235401   Нажмите на изображение для увеличения
Название: IMAG1880_1.jpg‎
Просмотров: 6
Размер:	46.1 Кб
ID:	1235402   Нажмите на изображение для увеличения
Название: IMAG1879_1.jpg‎
Просмотров: 13
Размер:	66.1 Кб
ID:	1235403   Нажмите на изображение для увеличения
Название: IMAG1876_1.jpg‎
Просмотров: 10
Размер:	66.2 Кб
ID:	1235404   Нажмите на изображение для увеличения
Название: IMAG1873_1.jpg‎
Просмотров: 6
Размер:	46.8 Кб
ID:	1235405   Нажмите на изображение для увеличения
Название: IMAG1877_1.jpg‎
Просмотров: 12
Размер:	56.7 Кб
ID:	1235406   Нажмите на изображение для увеличения
Название: IMAG1881_1.jpg‎
Просмотров: 4
Размер:	33.5 Кб
ID:	1235407  

  26. #13063

    Регистрация
    09.12.2008
    Адрес
    Астрахань
    Возраст
    50
    Сообщений
    2,508
    Цитата Сообщение от Neo0 Посмотреть сообщение
    Проверил ещё раз настройку с выключенными каналами кроме roll, настраивал с нуля. Эффект сохраняется при любых значениях.
    Так же снова менял местами двигатели, безрезультатно.....:
    Ну еще... крайнее, до чего я "додумался".... что может влиять:
    - сами проводочки от датчика попробовать закрепить в месте, близком, где они выходят из датчика (разъема датчика)... Т.е. сам проводочек при изгибании сильном может чуток сдвигать весь корпус (плату) датчика.....

    Это если конечно датчик очень крепко закреплен - тогда бесполезно.... Короче - проверить - не двигается ли датчик.... хоть немного... хоть на доли миллиметра. Если датчик закреплен на двусторонний скотч - то вполне возможно.
    На фотках не видно...

    У меня датчик на двух болтиках крепится.... По констукции предусмотрено так...

    Ну больше ничего... На большее моей "квалификации" уже не хватает
    Это у меня первый подвес, раньше ничего подобного не делал, опыта никакого.


  27. #13064

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Нет, датчик закреплён жёстко на два винта как у вас
    Думаю на геометрию. Сейчас думаю как выгибить обратно, аллюминий жёсткий довольно таки, руками не согнуть правильно. Либо тиски+молоток либо два болта подлиннее такого же диаметра как статоры и гнуть руками.
    Народ у кого такой же подвес есть и без крашей, гляньте плечо такое же как у меня или оси в одной плоскости и под 90* должны быть?

    P.S. Нашёл вот такой план подвеса, жаль пока нет в профиль. Но чую всё же что всё должно быть чётко под 90* и в одной плоскости.
    Миниатюры Миниатюры Нажмите на изображение для увеличения
Название: dys.png‎
Просмотров: 7
Размер:	27.1 Кб
ID:	1235423  
    Последний раз редактировалось Neo0; 27.07.2016 в 11:53.

  28. #13065

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    И судя по всему запчасть можно взять от Tarot 2D, они похоже идентичны и не только плечо (пикча с rcgroups):
    Миниатюры Миниатюры Нажмите на изображение для увеличения
Название: DSC03336.jpg‎
Просмотров: 28
Размер:	49.1 Кб
ID:	1235428  

  29. #13066

    Регистрация
    23.09.2015
    Адрес
    Ковров
    Возраст
    27
    Сообщений
    17
    Здравствуйте! Прошу помощи!
    Купил с рук подвес DYS smart3? Сначала он работал нормально, но никак не хотел "видеть" PWM-сигнал с пульта, хотел управлять PITCH! Перепробовал все входы, но так и не получилось, решил попробовать обновить прошивку. Там уже была версия 2.40b7 поэтому я просто прошил ее еще раз через GUI, все прошло штатно! После этого GUI не подключается к плате хотя функция прошивки работает, пробовал прошивать все версии, начиная с 2.3, они заливаются в контроллер, но результатов нет! При подключении к USB следует серия вспышек зеленого светодиода и все, от батареи вообще не подает признаков жизни, светится только красный диод.
    Кто-нибудь сталкивался с подобным, подскажите пожалуйста что можно сделать?

  30. #13067

    Регистрация
    23.09.2015
    Адрес
    Ковров
    Возраст
    27
    Сообщений
    17
    После прошивки 2.40b8 для неоригинальных плат, подвес заработал, но по прежнему не видит PWM с приемника! Подключаю 1 проводом, питание общее, выход приемника проверял сервой! В чем может быть причина?

  31. #13068

    Регистрация
    15.06.2011
    Адрес
    Ростов-на-Дону
    Возраст
    45
    Сообщений
    865
    Цитата Сообщение от Mechanick Посмотреть сообщение
    В чем может быть причина?
    убитый вход на атмеге ... пробовать подключать на другой вход или менять атмегу ... всеравно лицензии (загрузчика) в атмеге нет ...

  32. #13069

    Регистрация
    23.09.2015
    Адрес
    Ковров
    Возраст
    27
    Сообщений
    17
    Я тоже предполагаю, что порт убитый, т.к. ни один вход не работает, думаю сдуть атмегу с ардуино нано, загрузчик подходит! Очень удивлен, что плата не оригинальная, подвес вроде фирменный, да и контроллер цивильный! Возможно кто-то до меня убил родной загрузчик!

  33. #13070

    Регистрация
    09.12.2008
    Адрес
    Астрахань
    Возраст
    50
    Сообщений
    2,508
    Цитата Сообщение от Mechanick Посмотреть сообщение
    Здравствуйте! Прошу помощи!
    Купил с рук подвес DYS smart3? Сначала он работал нормально, но никак не хотел "видеть" PWM-сигнал с пульта, хотел управлять PITCH! Перепробовал все входы, но так и не получилось, решил попробовать обновить прошивку. Там уже была версия 2.40b7 поэтому я просто прошил ее еще раз через GUI, все прошло штатно! После этого GUI не подключается к плате хотя функция прошивки работает, пробовал прошивать все версии, начиная с 2.3, они заливаются в контроллер, но результатов нет! При подключении к USB следует серия вспышек зеленого светодиода и все, от батареи вообще не подает признаков жизни, светится только красный диод.
    Кто-нибудь сталкивался с подобным, подскажите пожалуйста что можно сделать?
    Именно с таким не сталкивался...

    У меня так:
    - от приемника идет к контроллеру (с канала, на котором крутилка управлять наклоном камеры)... а уже из контроллера - идет к одному из входов подвеса RC_Pitch - тем самым и от пульта могу управлять крутилкой наклоном камеры и еще сам контроллер коптера в режиме АВТО сам наклоняет камеру на запрограммированные точки (по высоте можно программировать)...
    - от контроллера - подключен к FC-roll - что бы "соглассовывать" и улучшать качество стабилизации...

    Т.е. может нужно посмотреть... не перепутан ли вход на плате подвеса...
    (имею ввиду RC-pitch и FC-pitch)...

  34. #13071

    Регистрация
    15.06.2011
    Адрес
    Ростов-на-Дону
    Возраст
    45
    Сообщений
    865
    Цитата Сообщение от Mechanick Посмотреть сообщение
    думаю сдуть атмегу с ардуино нано, загрузчик подходит!
    он то подходит , только прошивка с ним в память не влезет и затрет загрузчик ... нужно что нибудь мелкое , совместимое с ардуино , например optiboot ... так что перед тем как сдувать с ардуино поменяйте загрузчик ...
    Цитата Сообщение от Mechanick Посмотреть сообщение
    Подключаю 1 проводом, питание общее, выход приемника проверял сервой!
    на всякий случай проверьте земли ... земля должна быть толстой , чтобы под нагрузкой не было помех по земле ...
    физическую работоспособность входов можно попробовать проверить в аналоговом режиме ... для наглядности можно использовать CMD канал....

  35. #13072

    Регистрация
    23.09.2015
    Адрес
    Ковров
    Возраст
    27
    Сообщений
    17
    Цитата Сообщение от Gapey Посмотреть сообщение
    он то подходит , только прошивка с ним в память не влезет и затрет загрузчик ... нужно что нибудь мелкое , совместимое с ардуино , например optiboot ... так что перед тем как сдувать с ардуино поменяйте загрузчик ...
    на всякий случай проверьте земли ... земля должна быть толстой , чтобы под нагрузкой не было помех по земле ...
    физическую работоспособность входов можно попробовать проверить в аналоговом режиме ... для наглядности можно использовать CMD канал....
    Пробовал и с отдельной землей! В аналоговом режиме появляется условный сигнал и держится в районе 1500 (во вкладке диагностика), подключал реальный джойстик, так же нет реакции! Если прикоснуться пальцем к контактам сигнал хаотично прыгает, похоже как будто вход АЦП "висит в воздухе"! Насчет памяти в ардуино не совсем понял, сегодня прошил UNO через GUI неоригинальной прошивкой и ардуино подключилась как подвес, без проблем, потом обратно прошил ардуиновский скетч и тоже работает, так же и в подвес заливал всякие скетчи, смотрел данные с гироскопа, потом вернул прошивку. Может последние версии занимают меньше памяти!? Просто у меня программатора нет, чтоб загрузчик менять

  36. #13073

    Регистрация
    15.06.2011
    Адрес
    Ростов-на-Дону
    Возраст
    45
    Сообщений
    865
    Цитата Сообщение от Mechanick Посмотреть сообщение
    Просто у меня программатора нет, чтоб загрузчик менять
    загрузчик меняется с помощЪю USB-UART чипа на самой ардуине (если это полновесная ардуино а не мини/нано ... про загрузчик информация была от самого Алекса , что прошивка + стандартный ардуиновский загрузчик не влазят в флэш память ... в вашем случае в ардуине может быть изначально прошит альтернативный загрузчик ...

  37. #13074

    Регистрация
    10.07.2016
    Адрес
    Новосибирск
    Возраст
    26
    Сообщений
    13
    Народ... а как перепрошить полностью плату AlexMos 32 ? (если конечно есть в этом смысл.) Так как не могу понять что с ПИТЧ. дергается и не держит уровень. (движки местами менял, провода тоже, настройки разные пробовал) Единственное, авто для движков и там по ним полный бред пишется. то 189 для кол-во полюсов
    Последний раз редактировалось AntonFLY; 01.08.2016 в 07:24.

  38. #13075

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Цитата Сообщение от AntonFLY Посмотреть сообщение
    ...auto для движков и там по ним полный бред пишется. то 189 для кол-во полюсов...
    Аналогичная шляпа с каналом roll, уже какую неделю бьюсь.

    По итогу что дальше делал:
    - геометрию подвеса поправил, теперь все оси чётко под 90 градусов;
    - медное кольцо проставка не давала покоя и выступ цилиндрический на оси ROLL тоже, касались подшипников, решил убрать их в принципе;

    Авто настройка полюсов стала чище по ROLL но иногда всё же выбирает вместо 14 полюсов то 93 полюса, то 45.
    И это на любом моторе, менял местами с PITCH (При этом PITCH Всегда работает отлично)

    Жду новые моторки, пока. На неделе уже должны прийти. Хотя сомневаюсь что в них дело.

  39. #13076

    Регистрация
    10.07.2016
    Адрес
    Новосибирск
    Возраст
    26
    Сообщений
    13
    У меня по ПИТЧУ. по РОЛЛу все отлично и все логично. Настраивается и видно что горизонт держит.
    А ПИТЧ дергается и ни как не хочет приближаться к горизонту. Куда подвес туда и камера. Вверх и камера вверх плюс дерганье.

    Мотор менял. Провода менял. Фазы вот только не звонил. Подозреваю что канал контроллера....
    Геометрия... я так понимаю она не должна так сильно влиять. Он должен хоть как то пытается держать уровень.
    Гироскоп то же врядли. Каналу вообще все равно куда стрелка смотрит. Такое впечатление что включен фоллоу. Но так все выключенно.
    Epprom сбрасывал.
    Вот думаю перепрошить... но как... или уже покупать еще одни контроллер но уже фирменный.

  40. #13077

    Регистрация
    15.06.2011
    Адрес
    Ростов-на-Дону
    Возраст
    45
    Сообщений
    865
    Цитата Сообщение от AntonFLY Посмотреть сообщение
    Вот думаю перепрошить...
    а в чем проблема перепрошить то ???? версия как я понял 32 бит ...
    заходим в гуи ,вкладка обновление , автоматическое , жмем кнопочку прочитать , затем проверить , и получаем список доступных прошивок ...
    если поставить галку в воле Check for beta versions то будут доступны также последние публичные бэта версии ...
    вибираем какая больше нравится и нажимаем прошить ... дальше гуи запрашивает на сервере нужную прошивку и прошивает в плату ...
    так же в окошке ниже будут краткое описание изменений в этой версии , ссылки на скачивание соответствующей документации и нужной версии ГУИ.
    если есть подозрение что чтото нетак с каналом на плате , то можно выбрать другой канал для проблемного мотора , вкладка дополнительно , группа выходы на моторы.

  41. #13078

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Ну ведёт то себя так же как у меня. А если закрепить подвес, подать питание, внешнего воздействия не оказывать, то не дёргается?
    У меня к примеру стоит ровно, но потом замечаю что начинает плыть горизонт, при этом калибровка не влияет. В GUI показывает что датчик стоит ровно по горизонту, а камера уже ан 5 градусов отклонилась
    Ну, а если подвес дёргать то по проблемной оси дёргается и не возвращает сразу на место ось по горизонту.
    Плата у меня оригинальная, прошивки менял несколько раз (для неоригинальных не пробовал)

  42. #13079

    Регистрация
    07.07.2016
    Адрес
    Москва
    Возраст
    36
    Сообщений
    74
    У меня вопрос. В чем функциональная разница между 8 и 32 битами ?

  43. #13080

    Регистрация
    03.01.2011
    Адрес
    Москва, Раменское
    Возраст
    33
    Сообщений
    646
    Цитата Сообщение от Gapey Посмотреть сообщение
    если есть подозрение что чтото не так с каналом на плате , то можно выбрать другой канал для проблемного мотора , вкладка дополнительно , группа выходы на моторы.
    Это пробовал. Получается полная ерунда.
    Как я понимаю это то же самое что взять и перепаять кабель от одного мотора на канал другого.
    Ясно что настройки PID нужно тоже менять при этом, менял. И координаты датчика тоже менял. Не выходит.
    Может я дико туплю. Подскажите по шагам как проверить работу оси ROLL или PITCH со сменой канала?
    Я делал так:
    - в дополнительно выключаю все каналы, ставлю для оси ROLL канал PITCH;
    - лезу в Базовые, меняю для ROLL оси PID, так как сменился канал (тут я сомневаюсь что это нужно было делать);
    - сохраняюсь, калибруюсь;

    Цитата Сообщение от Basia Посмотреть сообщение
    У меня вопрос. В чем функциональная разница между 8 и 32 битами ?
    По идее в разрядности ШИМ. Чем больше разрядность тем плавнее будет на выходе управляющая характеристика.
    То есть из цифрового кода типа 1101011110101 получится переменное напряжение для контроля двигателем.
    Выше разрядность, плавнее работает мотор.
    Или не так?
    Последний раз редактировалось Neo0; 01.08.2016 в 13:43.

+ Ответить в теме

Похожие темы

  1. Бесколлекторные моторы для подвесов и всё что с этим связано!
    от Piranha в разделе Коптеры. Комплектующие, сборка, настройка.
    Ответов: 627
    Последнее сообщение: 28.12.2015, 15:52
  2. Продам Продам профессиональный Гексакоптер с гиростабилизированным подвесом
    от pilot340 в разделе Барахолка. Квадрокоптеры и другие многороторные системы
    Ответов: 9
    Последнее сообщение: 06.11.2015, 20:53
  3. Продам DYS Подвес 3-осевой под GoPro c платой AlexMos
    от dreel в разделе Барахолка. Квадрокоптеры и другие многороторные системы
    Ответов: 4
    Последнее сообщение: 28.07.2015, 16:56

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения