Доброго времени суток!

Имеется квадрокоптер WLToys V393, который после неудачного падения стал странно вести себя при синхронизации с пультом. Расскажу подробнее.
Во время полета малость не рассчитал и квадрокоптер побившись о ветки застрял на дереве, после чего упал с него в что-то вроде лужи. Дома я его разобрал, просушил, почистил, но при включении и самотестировании у него один из моторчиков не работал. Т.е. 3 потора делают слегка поворотные движения и все, а тот, что сломан тупо зацикливал это движение с характерным цоконьем. Думал заменить моторчик и полез разбирать луч (моторчик впаян). Решил сначала поменять местами 2 моторчика, чтобы понять, точно ли в нем дело. Перекинув 2 мотора, оба заработали и квадрокоптер нормально включался. Вернув все на место, квадрокоптер также включался и нормально летал и т.д. Я решил, что от падения появились микротрещины в пайке или т.п. В целом, после этого момента, с моторчиком проблема была решена и не возвращалась.Но выявилась еще одна неприятность. Иногда, при включении коптера он не коннектится к пульту. Методом научного тыка я выяснил, что все получается, если тупо отсоединить от платы кабель, идущий на диод индикации заряда и направления коптера. Т.е. я беру отключаю кабель, подключаю пульт и возвращаю кабель на место, все работает. После пары - тройки раз это перестало действовать и я стал отключать вместо диода что-то другое (точно не помню), а потом снова диод и так по кругу. Проще говоря, чтобы пульт увидел коптер, надо на этом коптере что-то отключить на плате. Есть ощущение, что могло что-то замкнуть на этом луче, с кривым моторчиком. Где-то тут на форуме читал, что у человека была ситуация с замыканием подсветки луча, при которой все работало, но коптер вел себя странно (не хотел лететь ровно и проч.). Но при всех моих попытках я пока не нашел КЗ на плате или луче, не нашел ничего подозрительного. Вероятно кто-то сталкивался с чем-то похожим или просто знает что это может быть. Буду благодарен!